What I’ve been UP TO

That past week I had lots of time for new experiences, ’cause you know I’ve got nothing to do and I hate doing nothing so I try to do little of this and that, anyway as may see my last post I’ve installed the whole Visual Studio 2008 Team System package (Team Suite and Team Foundation Server) and I’m glad I could make it that fast.

After I’ve been trying to install v20.0.015 firmware on my brother’s nokia N95, and the NSU (Nokia Software Updater) keep getting me "Downloading Update Failed." error and sometime with some more information about "Connection to the server lost" or something like that and after lots of trail and errors I got it, that was my ISP problem "Datak Telecom http://www.datak-telecom.com " and yesterday they fixed the thing and I did the upgrade first thing in the morning and by lunch time the N95 was patched with the new firmware. This is amazing, the phone is almost faster I mean in every aspects this firmware had its own effects. Now I can run applications side-by-side as much as one, none will disturb the others thanks to application demand paging. Also I found Nokia Energy Profiler http://www.forum.nokia.com/main/resources/development_process/power_management/nokia_energy_profiler/ which will help you to identify how much of the phones power (battery power) is drained in real-time, by real time I mean it just take a look and you’ll know what I mean, I’ve tested lots of applications together and I saw the Accelerometer is taking more power than you may thing!! so may be you give it try and let me know what else you found out by leaving me a comment.

Another thing I’ve been up to was upgrading to Windows Server 2008 November CTP, I’ve got the DVD so late but late is better than never, so I’ve tried to upgrade the Windows Server 2008 RC0 6001.16659.070916-1443 to Windows Server 2008 November CTP 6001.17042.071107-1618 and I want to see how smooth did this will go, and I tell you this is smoother that you might thing. Everything is alright but just these:

  • Windows Server 2008 Still got the same problem with Marvell Yokun 88E8056 PCI-E Gigabit Ethernet Controller of my Gigabyte Technologies 965P-S3 Mainboard which is not good, so you have to disable the Ethernet controller from BIOS and then try to upgrade. (I’ve wrote about this problem ever since Windows Vista was released) and after the upgrade you may enable it again.
  • The other problem I had was that the Windows Server 2008 just set default service configuration back, I mean I have started the "Windows Audio Service" or Ive disabled "Windows Firewall Service" but they are all gone back to their default settings, but that wasn’t a pain in the a.. but I’m sure they have a good reason for that.
  • After the upgrade, all not connected devices gone, but that’s not bad.
  • Some application like Windows Media Player needed to be reconfigured, that not very bad either.

That was all, everything else was right there as it was before. If you have some questions here, may be you leave me a comment and I test and tell you what!

But I gotta tell you something, if you are using RC0 you need to upgrade, this is just harmless, you can use the same "Product Key" to register and there is no problem there.

The Windows Server 2008 FREAK,

Sadjad Bahmanpour

1 thought on “What I’ve been UP TO”

Leave a Reply