Security Update for the Microsoft Visual Studio 2005 Service Pack 1

In couple of days back microsoft released an update named "Security Update for the Microsoft Visual Studio 2005 Service Pack 1 (KB937061)" http://support.microsoft.com/kb/937061 and I’ve approved it in WSUS 3.0, but after my client computers installed this update some of them keep alerting to install this and when I check this out in WSUS report viewer it says they’ve just downloaded it but never installed it. So I’ve checked the web and I found some people have the same problem: http://groups.google.com/group/microsoft.public.windowsupdate/browse_thread/thread/4440ecfcf23c3efa/afdac2ce02cc7261?  so my answer for all the people with same problem would be:
 
I use WSUS 3.0 for update distribution in my org, I’ve got the same problem on 2 of 3 machines:
 
Windows Server 2003 EE SP2, VS Team Suite: Installed but keep comming (on WSUS showed downloaded but not installed yet)
Windows Vista Ultimate Edition, VS Team Suite: Installed but keep comming (on WSUS showed downloaded but not installed yet)
Windows Server 2003 EE SP2, VS Team Suite: Installed and never come agian (on WSUS showed installed)
 
So I’m going to check the differences on those to machines (one OK one not), these two are all same (I mean by hardware these are twins) ….
 
So about get rid of it (just for now till I found something else or they replace it), first check out VS about box and see if the update been installed there or you can check this out on Add/Remove Programs, so if it is istalled and you think it’s ok, you can just hide the update (in Vista right click -> hide, in others uncheck when asked for install and ok the hide poped message)
 
Update #1: The other machine with no problem has joined the other machines!!! Now all my computers have the same problem and keep alerting for installing this update and in WSUS report shows that they’ve just downloaded the update!!!!
 
Update #2: It appeared that this is not only me having this problem check this out http://www.winbeta.org/comments.php?shownews=10046 and you’ll see others have too! at the end of this post it wrote:
 
"If you have VS 2005 SP1 present but the Crystal Reports feature is not present, MS07-052 is re-offered. Customers are protected and are not at risk to this vulnerability We will be updating the detection on Microsoft Update, customers that have already installed this update need to take no action. We are working to resolve this issue and it should be fixed shortly Thank you" – Eric Brodish, Microsoft Corp (microsoft.public.windowsupdate)"
 
And for further information about this check out http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=2126818&SiteID=1.
 
So this would make me HATE Crystal Report EVEN MORE!
 
If you found some other solutions please comment here!!!
 
Update #3: It seems that microsoft has revised the update (the update metafile which shows how to detect) and by now your problem sould be solved just like me! So first sychronize your WSUS and then synchronize your client machines, but if the problem still there (in my Windows Server 2003 the problem was not resolved!) first stop the "Automatic Update Service" then delete the C:WindowsSoftwareDistribution folder contains and also C:WindowsWindowsUpdate.log and start the update service again and now resynchronize the client machine "wuauclt /detectnow".
 
If found this helpful please leave me a comment.
 
Thanks for your time,
Sadjad Bahmanpour

Leave a Reply