Mysterious Update in WSUS 3.0

Today a new product was added to WSUS 3.0 which I think is very new (I mean very beta) "Microsoft Forefront Unified Security Gateway (USG) Definition Updates for HTTP Malware Protection", I’ve searched the web and no result. I’ve just selected it and there was some new updates comming for this, something like "Forefront Client Security Definition Updates".
 
As far as I see this could be something around Stirling http://www.microsoft.com/forefront/prodinfo/roadmap/stirling.mspx maybe some antivirus plug-in for ISA Server 2006 or something about ISA Server 2008 or who knows maybe about mixature of all of them.
 
If you feel something about this "Tell me about it!".
 
Update #1: I see some others whom mentioned it here http://www.eggheadcafe.com/software/aspnet/30841155/what-is-forefront-unifie.aspx but there should be more people asking about this, why not, I don’t know?
 
Update #2: YEAH, I was right, today microsoft rename the category to "ISA Server codename Nitrogen, Definition Update for HTTP Malware Protection" and thats what I’ve told you about, so now I want this new product to give it a test drive and see how this work. If you have any new information about Microsoft Forefront Edge Security (ISA Server 2008) please leave me a comment.
 
Sadjad

Windows Server 2008 RC

These days I’ve been busy playing around with new Windows Server 2008 RC0 Enterprise Edition to see when can I start to migrate, WOW, I’ve just migrated! I can’t tell you how good I feel about this, THIS IS FAR MORE BETTER THAN Windows Server 2003, I have to tell it out load because this server windows solved all annoying things in windows server 2003.
 
So about stability this is all good, I mean you can install this as your main windows, but I also kept my installed windows server 2003 for some security reasons. So I’m gonna write down my review about this great product here one-by-one:
 
  • Faster boot time even in domain-joint mode
  • All same UI as vista so you can have vista anytime you want, you just need mouse pointer file copied from an installed vista and also you may can copy media center or may be dream sence (if this would be possible! WOW)
  • There is no compatiblity option on executable files for Compatible as Vista, maybe this is a bug or this is a good feature, I mean being all the same
  • CD/ DVD Burning features all as Vista
  • No feature/ Roles are enabled by default and this is good all managable and all is in your hand
  • Forefront Client security is fully compatible
  • All Vista drivers can be used, no problems here
  • Less restart needed than server 2003
  • The IE is faster, you must disable IE ESC at least for administrator and I also disabled Windows Firewall Services and also disabled QoS service on my LAN card
  • There is still the same problem via Marvell Lan Cards, refer http://sadjadbp.spaces.live.com/blog/cns!21F12BB61B822DFA!145.entry for my work around
  • I cannot play DVD from my external drive with Windows Media Player/ Media Player Classic but Media Player Calssic can play DVDs from DVD drive and also if I use win2k8Videos style I could play DVDs from external HDD but still no help on Windows Media Player
  • The number of pre-installed codec are only 72 or something which is very good, there is no default DVD decoder installed which is better than VISTA
  • The Start Menu and Seach Feature are very good/ fast
  • I couldn’t find "Windows SideBar" but "Windows SideShow" is here and working
  • The defualt memory usage is something around 370MB (without aero theme) which is not bad
  • No problem on Sound/ Video playback or codecs everything are compatible
  • No application crashes like what vista do alot
  • Sharing is done with a whole new way which is so much better, you just select which user and Server do all the rest
  • THIS IS GOOD!

Anyway this what I tested till now, I’ll update if I see something interesting! If you want something that I can test for you just leave me comment here!

Update #1: The DVD playback in Media Player Classic is now OK, the problem was because I made my SONY DVD Player/Drive Region Free via RPC1 which can be found in http://forum.rpc1.org . I enable the RPC2/ DVD Region of the drive and reinstall the Server 2008 and MPC is now ok, but there is still problem via Windows Media Player which says "Windows Media Player cannot play DVD video. You might need to adjust your Windows display settings. Open display settings in Control Panel, and then try lowering your screen resolution and color quality settings." I think I have to copy msmpeg2vdec.dll and msmpeg2adec.dll from my installed Windows Vista Ultimate, I think the Windows Media Player 11 for Vista/Server 2008 just like microsoft mpeg-2 decoder and I have gabet one, So I’m gonna test that …

Update #2: Windows Live Photo Gallery beta will be installed but cannot be started because an error from Microsoft SQL Server 2005 Compact Edition, so I just downloaded it from here http://www.microsoft.com/downloads/details.aspx?FamilyID=85E0C3CE-3FA1-453A-8CE9-AF6CA20946C3&displaylang=ru and installed it after Windows Live Photo Gallery and now everything is ok, I think this is intalled by default on Vista.

Update #3: I’ve just overcome the DVD playback problem WOW, This was about codec. I’ve used this combination to solve this problem: Gabest Mpeg Splitter (MpegSplitter.ax), NVidia PureVideo (as MPEG-2 decoder), Gabet DirectVobSub (VSFilter.dll), DivX Pro (AVI codec) this is it, this would play everything. I’ll write about codecs sometimes in near future, ’cause I see lots of people install lots of codecs to set things working. The only left problem is that I cannot play DVD’s from my External HDD (USB Western Digital Premium) nor in media player niether on MPC both said something about region. My workaround would be the old Sharing Trick, I meant I’ll access the drive by win2k8Movies and they never know this is external drive or internal. I have the problem on my Vista Ultimate.

Sadjad Bahmanpour

 

Security Update for the Microsoft Visual Studio 2005 Service Pack 1

In couple of days back microsoft released an update named "Security Update for the Microsoft Visual Studio 2005 Service Pack 1 (KB937061)" http://support.microsoft.com/kb/937061 and I’ve approved it in WSUS 3.0, but after my client computers installed this update some of them keep alerting to install this and when I check this out in WSUS report viewer it says they’ve just downloaded it but never installed it. So I’ve checked the web and I found some people have the same problem: http://groups.google.com/group/microsoft.public.windowsupdate/browse_thread/thread/4440ecfcf23c3efa/afdac2ce02cc7261?  so my answer for all the people with same problem would be:
 
I use WSUS 3.0 for update distribution in my org, I’ve got the same problem on 2 of 3 machines:
 
Windows Server 2003 EE SP2, VS Team Suite: Installed but keep comming (on WSUS showed downloaded but not installed yet)
Windows Vista Ultimate Edition, VS Team Suite: Installed but keep comming (on WSUS showed downloaded but not installed yet)
Windows Server 2003 EE SP2, VS Team Suite: Installed and never come agian (on WSUS showed installed)
 
So I’m going to check the differences on those to machines (one OK one not), these two are all same (I mean by hardware these are twins) ….
 
So about get rid of it (just for now till I found something else or they replace it), first check out VS about box and see if the update been installed there or you can check this out on Add/Remove Programs, so if it is istalled and you think it’s ok, you can just hide the update (in Vista right click -> hide, in others uncheck when asked for install and ok the hide poped message)
 
Update #1: The other machine with no problem has joined the other machines!!! Now all my computers have the same problem and keep alerting for installing this update and in WSUS report shows that they’ve just downloaded the update!!!!
 
Update #2: It appeared that this is not only me having this problem check this out http://www.winbeta.org/comments.php?shownews=10046 and you’ll see others have too! at the end of this post it wrote:
 
"If you have VS 2005 SP1 present but the Crystal Reports feature is not present, MS07-052 is re-offered. Customers are protected and are not at risk to this vulnerability We will be updating the detection on Microsoft Update, customers that have already installed this update need to take no action. We are working to resolve this issue and it should be fixed shortly Thank you" – Eric Brodish, Microsoft Corp (microsoft.public.windowsupdate)"
 
And for further information about this check out http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=2126818&SiteID=1.
 
So this would make me HATE Crystal Report EVEN MORE!
 
If you found some other solutions please comment here!!!
 
Update #3: It seems that microsoft has revised the update (the update metafile which shows how to detect) and by now your problem sould be solved just like me! So first sychronize your WSUS and then synchronize your client machines, but if the problem still there (in my Windows Server 2003 the problem was not resolved!) first stop the "Automatic Update Service" then delete the C:WindowsSoftwareDistribution folder contains and also C:WindowsWindowsUpdate.log and start the update service again and now resynchronize the client machine "wuauclt /detectnow".
 
If found this helpful please leave me a comment.
 
Thanks for your time,
Sadjad Bahmanpour

Windows Live Photo Gallery

Last night I’ve installed new Windows Live Suite 2.0 on my laptop and everything was all right and then I’ve tried to install WLinstaller.exe on my PC with Windows Server 2003 Enterprise Edition and AGAIN someone in windows live team forget US (The Windows 2003 LOVERS!) so the application couldn’t start because it can’t be install on windows server systems. So I had to do something about it and I did and today I saw that someone else used this trick to install it on x64 systems and now I’m proud of myself and think to my self why didn’t I published this faster than him on www.LiveSide.net.

So anyway you just need to grab the installers from C:WindowsSystem32configsystemprofileAppDataLocalWindowsLiveInstallerMsiSources from some machine with Windows Vista and run them anywhere you’d like and this is the link to liveside.net "64 Bit Systems And The New Live Installer- A Solution" but believe me I DID IT FIRST :D.

And this is original post http://www.anti-tgtsoft.com/?p=14 thanks man!

Whatever may be I can hack this installer and make it do what I want, who knows!

After installing I’ve checked Windows Live Photo Gallery which I love because I make me feel better for Windows 2003 Server (Some new feature from Vista right into Win2k3) and I just like it more, it is good but there is still one problem in it (I’ve found it before and it is still here) and this is it:

After installing Windows Live Photo Gallery if you check your system’s CODEC’s (I did it via GSpot) you’ll notice some unregistered CODEC named "WLXVAFilt.dll" so you can solve this problem by running following command after installing WLFoG:

regsvr32 "C:Program FilesWindows LivePhoto GalleryWLXVAFilt.dll"

 

So anyway enjoy this great application (also other windows live friend of it) and remember to leave comments if you found this helpful.

Sadjad Bahmanpour

WSUS Synchronization History Cleanup

Today I’ve been synchronizing my friend’s WSUS (Windows Server Update Services), I was in middle of this work that I remembered to check my server "Synchronizations History", WOW this is taking so long (387 history), now I know what I want!
 
"A Solution to clean or cleanup the Synchronization History in WSUS 3.0":
 
So I’ve tried to search the web but no one has the answer but some have the same question which I’d love to hear from them, so then I’ve tried to monitor the SQL Server 2005 via the Management Studio -> Management -> Activity Monitor, and takes about an hour to find these:
 
First "tbEvent", "tbEventInstance", "tbEventMessageTemplate" so check them table out and you’ll see what I see! I’ve got 5000+ events in my "tbEventInstance Table" and thats where my synchronizations are! so you can just simply clear the table via:
 
DELETE FROM [SUSDB].[dbo].[tbEventInstance]
 
I didn’t do that but you may! This might clear all the events occured from the start till now.
 
So second I’ve checked "tbEventMessageTemplate Table" where there is a message for every EventID. check them out and you’ll see Event ID’s between 381 and 387, they are all about synchronization.
Now you may execute this:
 
DELETE FROM [SUSDB].[dbo].[tbEventInstance]
WHERE [EventID]=381 or [EventID]=382 or [EventID]=384 or [EventID]=386 or [EventID]=387
 
and this is what I do and now I have no synchronization history and this will done as fast as possible (means in no time!).
 
So you may now do this after every "Server Cleanup Wizard"! Who now may be someday them Microsoft Workers add this there to…
 
Thanks for reading this and feel free to submit a comment if this helped you!
If you want to refer this site please use "Permalink"!
 
Sadjad Bahmanpour

Windows Live OneCare Safety Scanner Script Error

If you read my last post about it http://sadjadbp.spaces.live.com/blog/cns!21F12BB61B822DFA!149.entry , you’ll know that I still have this problem, but today I’ve searched and now this is gone and I am doing the Safety Scan right now, so the solutios would be:
 
 
1. Quit all Windows-based programs.
2. Click Start, click Run, type regedit in the Open box, and then click OK.
3. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINESoftwareMicrosoftInternet ExplorerMainFeatureControlFEATURE_LOCALMACHINE_LOCKDOWN
4. In the FEATURE_LOCALMACHINE_LOCKDOWN subkey, follow these steps:a.  Click Iexplore.exe.
b.  On the Edit menu, click Modify.
c.  In the Value data box, type 0, and then click OK.
d.  Click Explore.exe.
e.  On the Edit menu, click Modify.
f.  In the Value data box, type 0, and then click OK.
5. To quit Registry Editor, click Exit on the File menu.
6. Restart Windows.
 
II) This is what worked for me:
IE -> Internet Options -> Tools -> Advanced -> Security -> (Uncheck) Allow active content to run in files on My Computer
Restart IE.
 
 
WOW this was all,
Sadjad Bahmanpour

Western Digital Buggy Firmware

A week ago I’ve did something which made me horrible week! I had a Western Digital (WD) My Book Premium 320GB and you know me I’ve been searching the WD Support web page http://support.wdc.com and I see a new firmware located http://support.wdc.com/download/index.asp?cxml=n&pid=19&swid=65 named "WD My Book Pro/Premium Firmware Update utility v1.08a" and I’ve download it and installed it (MyBook_Firmware_r1_08a.zip)!

And in middle of installing firmware after erasing, it says there was an error in updating firmware and POOOOOF my WD 320GB turned off! I tried to disconnect it from USB and connecting it again and windows 2003 server detect it as a "Blank Oxford USB Device"! What can I do next?

So after hours of research on the WEB I’ve realized that the external case had a chip which made by Oxford Semiconductor http://www.oxsemi.com/ and the chip number is 924DS or OXUF924DSA which is something like this http://www.oxsemi.com/products/storage/OXUF924DSB.html; I had folder under Program Files name "Oxford SemiconductorFirmware Upgrade"; So I’ve searched more and found a utility called "Oxsemi Updater Utility" which use "win_uploader_dll.dll" as main code and a JAVA SWING wrapper for the UI, so I’ve downloaded the last version which was made for 911 chipset’s and replaced the DLL with the one that firmware installed for me so I’ve created the Updater Utility v3.1.0.3 but there still nothing I cannot update the FIRMWARE; I have the latest firmware I need which is UF924DS_release.bin but the updater utility may not work on 924DS chipset!

So I feel USELESS!

I’ve emailed the OXSEMI’s but no answer and also the WD SUPPORT! You can see the support team replies below:

 

Firmware problem

Discussion Thread

Response (WD Support and Service)
09/06/2007 09:33 PM 

Dear Sadjad,
You recently contacted us by email for support on 8/27/2007.
We value your business and appreciate the opportunity to assist you.
To help us ensure that we maintain a consistent level of service and
support and to learn of areas where we can improve in customer service
and support, we would like to get your satisfaction feedback.
As a token of our appreciation for completing the survey, WD will give
you a coupon valid for $15 on purchases of $150 or more at the Western
Digital Online Store. The WD store carries all of the latest WD products
and offers free shipping on orders over $200.
Please provide us with your feedback by clicking on the link below.
Customer Satisfaction Survey Link:
http://websupport.wdc.com/rd.asp?p=es&ct=2&t=131&c=GEIDlI.&l=en
Sincerely,
Western Digital Technologies
http://www.wdc.com/
********************************************************************
Useful Links:
http://websupport.wdc.com/rd.asp?p=kb&t=47&l=en
Ask WD – knowledge base and FAQ.
http://websupport.wdc.com/rd.asp?p=he&t=48&l=en
Create RMAs, get warranty status, check RMA status, get shipping
and packaging information, change your contact information, and more.
http://websupport.wdc.com/rd.asp?p=dn&t=49&l=en
Download drivers, software, diagnostic and installation utilities.
http://websupport.wdc.com/rd.asp?p=dz&t=113&l=en
Dantz Retrospect Express – Back up related information
********************************************************************
If you do not want to receive future email support survey from us,
please use the link below.
http://websupport.wdc.com/mail.asp?e=sadjad_bp@hotmail.com&l=en

Customer (Sadjad Bahmanpour)
09/06/2007 03:33 PM 

I’m sorry for YOU not for me, THIS IS NOT A SUPPORT you are giving me.
You better put a HAZARD SIGN in your firmware page, and say there "IF YOU WANT TO DUMP YOU DATA AND NEVER SEE THEM AGIAN AND BE DISRESPECTED SO GO AHEAD AND DOWNLOAD THIS CRAP!" you better do that!
And by the way I’m gonna do what I can do to YOU, YOU COMPANY (WD), OXFORD SEMICONDUCTOR to RESPECT the customer, ’cause we pay you and you need to SUPPORT US!
I’m very sorry for WD!

Response (Don S.)
09/06/2007 10:06 AM 

Dear Sadjad,
Thank you for contacting Western Digital Customer Service and Support.
I am sorry, but again if the drive is not accessible you would need to look into data recovery options since we do not provide this type of support, and opening the external enclosure would void your warranty.
Sincerely,
Don S.
Western Digital Service and Support
http://support.wdc.com

Customer (Sadjad Bahmanpour)
09/01/2007 05:15 AM 

This is not a good support you have here, and This is not a good answer! "If the hard drive or data is no longer accessible then it is not likely we can get to the data" this is an external drive so if the firmware is gone, so the external drive is gone, but what about the internal drive it is good, if you’ve mentioned the URL I have sent you, you can see people open the drive and use their internal drive and everything is good! but I DO NOT WANT to OPEN the case I want you or Oxford Semiconductor hand me a fix! Something that FIX the drive for me, because YOU MAKE THIS BUGGY and YOU HAVE TO MAKE I WORK AGAIN.

Response (Don S.)
08/31/2007 10:41 AM 

Dear Sadjad,
Thank you for contacting Western Digital Customer Service and Support.
If there was an issue updating the firmware on the drive, it is likely cause because the drive has failed or was failing. If the hard drive or data is no longer accessible then it is not likely we can get to the data. However, you may use one of Western Digital’s authorized data recovery companies. In order to retain the warranty on the drive, you must use one of the authorized companies listed in the link. Please visit the link below for more information about these companies and our data recovery policy.
Title: How can I obtain a circuit board, repair my drive, recover data on my drive, or find a list of WD data recovery partners?
URL: http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/std_adp.php?p_faqid=70&p_created=1003446260
Title: How can I replace a product under warranty?
URL: http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/std_adp.php?p_faqid=8&p_created=1003424317
Sincerely,
Don S.
Western Digital Service and Support
http://support.wdc.com

Customer (Sadjad Bahmanpour)
08/31/2007 09:59 AM 

What do you mean by "You have a failed drive since it could not complete the upgrade process", You are MAKE it my FAULT?
I do not think so, I want all my 320GB of data! THIS IS YOU BUGGY FIRMWARE WHICH DID THAT, no me! So this time try not to answer me about replacing the device, I’m asking for a FIX of my device.

Response (Jeremy H.)
08/31/2007 08:52 AM 

Dear Sadjad,
Thank you for contacting Western Digital Customer Service and Support.
You have a failed drive since it could not complete the upgrade process. If you cannot exchange the drive back through the place of purchase, see the following link:
Answer Title: How can I replace a product under warranty?
Answer Link: http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/std_adp.php?p_faqid=8&p_created=1003424317
Sincerely,
Jeremy H.
Western Digital Service and Support
http://support.wdc.com

Customer (Sadjad Bahmanpour)
08/27/2007 08:26 AM 

I’ve also found someone else in the web with same problem
"http://smartmoney.com.com/hard-drives/western-digital-my-book/4864-3186_7-31973275.html?ctype=msgid&messageSiteID=7&messageID=2468146&cval=2468146" please check these out, may be there is a big bug in the firmware, it first erase the flash and then fail!!!! please help me!!!

Customer (Sadjad Bahmanpour)
08/27/2007 06:40 AM 

I have downloaded "WD MyBook Pro/Premium Firmware Update utility v1.08a" from "http://support.wdc.com/download/index.asp?cxml=n&pid=19&swid=65" and I tried to install, everything went fine, except after erasing flash the firmware update utility prompt me with a failed message, and after that the hard drive is known as "Blank Oxford USB Device" it will not turn on and the blue lights are always off, I’ve tested the drive with some other computer and their windows just recognize a new hardware and no HDD.
And I also found someone else in the web with same problem and All the same "http://forums.devshed.com/computer-hardware-103/external-hdd-my-book-pro-dead-after-failed-firmware-upgrade-463204.html" I know that this is only firmware problem, can you please provide me with original firmware, because this is your firmware problem, I swear I did not turn the USB off or switch the power I have four of this device and I thank god I just upgrade one of them, please help me this is urgent.

Auto-Response
08/27/2007 06:40 AM 

Dear Sadjad,
The answer(s) below were automatically selected for you by our knowledge base. If the answer(s) do not address your question, please click on "Finish Submitting Question" and your question will be submitted to our support staff.
Title: Where to download WD software, utilities, and drivers for Western Digital products.
Link: http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/popup_adp.php?p_faqid=7&p_created=1003423281
Title: Improved fan behavior of the My Book Pro Edition II and My Book Premium Edition II Dual-drive Storage Systems.
Link: http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/popup_adp.php?p_faqid=1482&p_created=1164731298
Title: How can I tell if the noise or sound my drive is making is normal?
Link: http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/popup_adp.php?p_faqid=568&p_created=1033495201
Title: How to rebuild a RAID 1 (Mirrored) array on a WD My Book Pro II or WD My Book Premium II Dual-drive System.
Link: http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/popup_adp.php?p_faqid=1491&p_created=1166814553
Title: Limitations related to the WD My Book World Edition hard drive.
Link: http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/popup_adp.php?p_faqid=1522&p_created=1172602981
Title: How to connect and disconnect a WD My Book Premium ES Edition hard drive.
Link: http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/popup_adp.php?p_faqid=1501&p_created=1170718187
Title: I can’t use the Unplug or Eject Hardware icon to stop my FireWire or USB drive in Windows.
Link: http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/popup_adp.php?p_faqid=274&p_created=1023392680

 

 

They just want the drive to replace it, but I want them to ADMIT that they do that and they have to give me the firmware! But neither them neither Oxsemi answered me!!!! So I did something to help me! I’ve called some friend (MEM THANK YOU SO MUCH!!!!) and he hooked me up with the MANGER of WD SUPPORT in IRAN and after 10 days and 200$ they’ve recovered my drive and also replaced the drive with some My Book Premium 500GB WOW!!!! This is the only thing I LOVE about this country you can do whatever you want just you need a FRIEND and MONEY (WHICH I WANT THE BOTH :D)!

 

So this was the story of my sad week! But now I’m happy (Thanks again MEM), so I just want to tell you NEVER INSTALL THIS FIRMWARE WD My Book Pro/Premium Firmware Update utility v1.08a" WHATEVER IT TAKES DO NOT INSTALL A FIRMWARE FROM WESTERN DIGITAL!!!! They won’t accept anything!!!

 

But now I have two "Western Digital My Book Premium 500GB" which means I’ve got plenty of spaces!!!

 

I’ve also was thinking about make this to RAID, but I couldn’t found an application to make to external USB drive RAID in widows 2003 server, I’ve found some command line commands "diskpart" but I didn’t use it ’cause I’ve just spend 200$ on my data and I don’t want to do it again right now!

So anyway thanks for reading this, If you had same problem just comment me so may be we can inform others not to do so…

Update #1: I’m sorry to hear this much of loss for people because of some shitty firmware made by OXFORD SEMICODUTOR, now I see http://anotherdeadblog.blogspot.com/ and some more people and I’m thinking for a way to spread this to the world: "DO NOT INSTALL THIS FUCKING FIRMWARE!". I’m loud enough??????????

So anyway good luck žádné jméno , Hamilton Pinto Jr. , Don Insalata , …

Update #2: Someone just email me about this BUGGY FIRMWARE:

Hi,
I read about yuor troubles with the firmware upgrade on MyBook.
http://sadjadbp.spaces.live.com/blog/cns!21F12BB61B822DFA!221.entry#post

Too bad that I had not read it BEFORE the firmware upgrade… now I have non working externad disk, too.

I do not care about the data loss (I have it backed up), but I do not want to return my HDD to reseller (have a business data on it). It is WD who screwed it with the buggy firmware upgrade software…

Have you found any solution to this (apart from returning it?)

Cheers
Jakub

I’m sorry to hear about this man, maybe we can do something about it! Lets everybody submit a question in http://support.wdc.com about same problem we have, maybe they do something about this, at least remove it from their website. So I’m going to Update my question, WILL YOU HELP ME?

Sadjad Bahmanpour